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Abstract

This document, which is also available using the online help system of XXE, describes the commands
which are specific to XHTML.
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1. Creating an XHTML document

The File → New dialog box allows you to choose between the following document templates:

DescriptionTemplate NameXHTML Ver-
sion

File having a .xhtml suffix, starting with an XML declar-
ation (<?xml version="1.0"?>) and a <!DOCTYPE>
pointing to the XHTML 1.0 Strict DTD.

XHTML Page (Strict)1.0

File having a .html suffix, having no XML declarationa

and starting with a <!DOCTYPE> pointing to the XHTML
1.0 Strict DTD.

HTML Page (Strict)

This document template is a well-formed, valid XHTML
file which is intended to be seen by Web browsers as an
HTML file.

File having a .xhtml suffix, starting with an XML declar-
ation and a <!DOCTYPE> pointing to the XHTML 1.0
Transitional DTD.

XHTML Page (Trans-
itional)

File having a .html suffix, having no XML declaration
and starting with a <!DOCTYPE> pointing to the XHTML
1.0 Transitional DTD.

HTML Page (Trans-
itional)
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DescriptionTemplate NameXHTML Ver-
sion

This document template is a well-formed, valid XHTML
file which is intended to be seen by Web browsers as an
HTML file.

File having a .xhtml suffix, starting with an XML declar-
ation and a <!DOCTYPE> pointing to the XHTML 1.1
DTD.

XHTML Page1.1

File having a .html suffix, having no XML declaration
and starting with a <!DOCTYPE> pointing to the XHTML
1.1 DTD.

HTML Page

This document template is a well-formed, valid XHTML
file which is intended to be seen by Web browsers as an
HTML file.

File having a .xhtml suffix, starting with an XML declar-
ation followed by <!DOCTYPE html> and conforming to

XHTML Page5.x

an XHTML 5 XML Schema and Schematron developed
by XMLmind. More information in About the XHTML 5
XML Schema and Schematron developed by XML-
mind [3].

File having a .html suffix, having no XML declaration,
starting with <!DOCTYPE html> and conforming to an

HTML Page

XHTML 5 XML Schema and Schematron developed by
XMLmind. More information in About the XHTML 5
XML Schema and Schematron developed by XML-
mind [3].

This document template is a well-formed, valid XHTML
file which is intended to be seen by Web browsers as an
HTML file.

aThis implies that the encoding of the file must be UTF-8 for this file to be successfully opened in an XML editor.

This is enforced by the fact that all document templates called "HTML Page" contain:

 <meta content="text/html; charset=UTF-8" 

       http-equiv="Content-Type" />

All the above document templates should be highly interchangeable between Web browsers and XML
editors, however it is worth keeping in mind the following points:

• If you want to feed your XHTML document directly to a Web browser, choose a document template
called "HTML Page".

• If you want to feed your XHTML document directly to a Web browser but your document also contains
MathML, choose a document template called "XHTML Page".

• If your XHTML document is a building block which is intended to be processed by an XML based
publishing system, choose a document template called "XHTML Page".

• More information in Activating Browser Modes with Doctype.
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About the XHTML 5 XML Schema and Schematron developed by
XMLmind

Combined together the XHTML 5 XML Schema and Schematron developed by XMLmind1

implement most of the conformance requirements for authors specified in the HTML Living
Standard (starting from the 2019-07-18 update). There are differences though:

• Attribute id may not contain space characters.
• Attributes like class, rel, itemref, etc which contain a list of tokens may not be com-

pletely empty.
• For compatibility with older HTML 5.x W3C Recommendations:

• The table element may have a border="1" or border="" attribute (which both means:
table has a border).

• The style element may have a type="text/css" or type="" attribute (which both
means: it's a CSS stylesheet).

Note that our in-house XHTML 5 XML Schema supports data-* attributes, ARIA role

and aria-* attributes and also custom elements.

2. Opening an existing XHTML document

• If your document starts with <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN">,
it will be detected as being an XHTML document associated with the XMLmind XML Editor (XXE
for short) configuration called "XHTML Strict".

Note that the XHTML 1.0 Strict DTD does not allow the body element to contain text other than
whitespace.

• If your document starts with <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transition-
al//EN">, it will be detected as being an XHTML document associated with the XXE configuration
called "XHTML Transitional".

• If your document starts with <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN">, it will
be detected as being an XHTML document associated with the XXE configuration called "XHTML
1.1".

• If your document does not start with <!DOCTYPE> and if its root element is html in the "ht-
tp://www.w3.org/1999/xhtml" namespace, it will be detected as being an XHTML document associated
with the XXE configuration called "XHTML 5".

• Otherwise your document will not be detected as being an XHTML document and you'll have to
customize one of the stock XHTML configurations if you want to open your document as an XHTML
one.

3. CSS stylesheets found in the View menu

The View menu allows to choose between the following two CSS stylesheets:

Semantic (default CSS stylesheet)

This stylesheet contains styles which are intended to reflect the purpose of each XHTML element.
This stylesheet makes it easy editing XHTML documents in a validating XML Editor such as XXE.

1These are found in XXE_install_dir/addon/config/xhtml/xsd/5/xhtml5.xsd (XML schema) and xhtml5.sch (Schematron).
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Note that in the "XHTML 5" configuration, the "Semantic" stylesheet dynamically applies the
style attribute to table elements such as table, colgroup, tbody, td, etc2. This counterbalances
the fact that, in XHTML 5, all attributes influencing table rendering (frame, rules, width, valign,
etc) have been removed from table elements.

Emulate Web Browser

This stylesheet emulates (to a certain extent) how a Web browser typically renders an HTML page.

When this stylesheet has been selected, XXE will dynamically apply all the CSS styles found in
style attributes, style elements and link elements pointing to CSS stylesheets.

Sometimes XXE will fail to detect a change in how the XHTML document being edited should be
styled. In such case, you'll have to reload the "Emulate Web Browser" stylesheet by reselecting
this item in the View menu. For example, the following changes will not automatically trigger style
changes:
• Modify the textual content of a style element.
• Paste a div element containing a style element having no scoped attribute.

When XXE finds errors in the CSS styles it attempts to apply dynamically, it will not
report these errors. Instead, it will log them in a special log called "User Styles". If you
suspect that XXE has found errors in your CSS styles, you may want to view the content

of this log by clicking the Show Message Log button in XMLmind XML Editor -
Online Help which is next to the status line found at the bottom of XXE's window3 and
then select "User Styles" from the Category combobox.

If you often use <div class="XXX"> and/or <span class="YYY"> elements in your
XHTML documents and want to see these elements properly styled using the
<link rel="stylesheet"> element found in the head of your XHTML documents,
you may want to make the "Emulate Web Browser" stylesheet your default one. In
order to do this, simply select this stylesheet from the View menu and then select Op-
tions → Customize Configuration → Save Views As Default4.

3.1. Ruby, form controls and embedded content

Both the above CSS stylesheets support ruby, form controls and embedded content (iframe, object,
video, etc). However in the case of the input form control, some attributes such as autocomplete,
list, maxlength, minlength, etc, are not yet supported.

The "Emulate Web Browser" stylesheet renders the following elements the same way as in a Web
browser, at the expense of a less convenient editing: ruby, the select form control and most embedded
content elements.

A demo document showing these features is available in XXE_install_dir/demo/xhtml5-objects.html.

2Only the style attribute and only the table elements, unlike the "Emulate Web Browser" stylesheet.
3Or simply right-click on the status line.
4If you are a consultant customizing XXE for a group of writers, you'll have to customize the XHTML configuration by adding
to it a windowLayout configuration element in XMLmind XML Editor - Configuration and Deployment.
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4.The XHTML menu

Paste As

Paste from Word Processor or Browser

Import the HTML copied to the clipboard by word processors or web browsers and intelligently
paste it into the XHTML document being edited.
• Extensive efforts are made to decently support the “non-filtered HTML” copied by MS-Word

to the clipboard.
• When an application other than MS-Word is used, the quality of the result you'll get in XXE

highly depends on what has been copied to the clipboard. In all cases, XXE tries very hard
to import something simple, clean and valid at the expense of the fidelity to the original data.

The pasted data replaces the text or node selection if any. When there is no selection, XMLmind
XML Editor automatically determines a valid insertion location at or following the caret position.

If XMLmind XML Editor fails to find such valid insertion location, the rich text is converted
to valid XHTML and then copied to the clipboard, overwriting the original data put there by the
third-party application. This allows to use the “normal” Paste Before, Paste or Paste After
commands to paste the data elsewhere in the document.

This menu entry allows not only to paste snippets copied from word processors or
web browsers, but also to import entire documents or HTML pages. In order to
import the entire document into XXE:
1. Open the document in the third-party application.
2. Press Ctrl+A (Select All) then press Ctrl+C (Copy) to copy it to the clipboard.
3. Create a new XHTML document in XXE by using File → New.
4. Use File → Save As to save this new XHTML document to disk.
5. Explicitly select the root element of the XHTML document, for example by

clicking on its name in the node path bar.
6. Select menu item "Paste from Word Processor or Browser" to paste the

content of the clipboard5.

If, using MS-Word, you want to copy a piece of text rather than a paragraph, do
not include the hidden character found at the very end of a paragraph (the paragraph
mark) in your selection.

Other menu entries

The entries of this submenu allow to paste the plain text copied to the clipboard, typically using
a third-party word processor or spreadsheet, as:
• one or more paragraphs,
• OR a pre element,
• OR one or more list items,
• OR an itemized list,
• OR one or more table rows,
• OR a table.

The last two menu entries assume that each text line specifies a table row and that, within a text
line, the contents of the table cells are separated by tab characters.

5Note that Ctrl+V, that is, the plain Edit → Paste command, would not work here.
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If you need to paste the copied text as an ordered list, first paste this text as an
itemized list then convert the pasted list to an ordered list using Edit → Convert
(Ctrl+T).

The following entries of this submenu allow to paste the image copied to the clipboard as:
• img,
• div (containing an img)
• figure (XHTML5 only).

Menu entry "img" replaces the text or node selection if any. When there is no selection, this
menu entry pastes its element at caret position (just like Edit → Paste).

All the other menu entries also replace the text or node selection if any. When there is no selec-
tion, these menu entries paste their elements at any valid position in the document following
the caret position.

Move Up

Move selected element up, that is, swap it with its preceding sibling node. Requires the element to
be explicitly selected.

Move Down

Move selected element down, that is, swap it with its following sibling node. Requires the element
to be explicitly selected.

Preview Settings

Displays a dialog box which may be used to specify one or more CSS stylesheets to be automatically
added to the preview.

This feature is useful when you use XXE to edit some “pure XHTML contents” (e.g. the text of an
article) and want to see how it will look like once published. This feature is not useful when you
use XXE to edit a self-contained HTML page, as this kind of page is expected to contain style
elements and/or links to its own set of CSS stylesheets.

Only the stylesheets for which the checkbox found in front of the CSS URL is checked will be added
to the preview. For example, in the case of the above figure, "file:/C:/src/9xxe/doc/re-
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sources/xmlmind.css" will be added to the preview6, not "http://www.xmlmind.com/xmledit-
or/xmdecor/xmlmind.css".

Safari users

Unlike all the other browsers, adding "file:/" CSS stylesheets to the preview will not
work unless you first enable the Developer tools (Preferences, Advanced tab, check
"Show Develop in menu bar").

Preview

Preview the document being edited using the “default viewer” helper application. The default
viewer is typically a Web browser. This helper application is specified in the Preferences dialog
box, Helper Applications section, Default viewer field.

Note that this command automatically creates a temporary preview file in any of the following cases:
• Some CSS stylesheets are to be automatically added to the preview. See above command [6].
• The XHTML document to be previewed contains XIncludes. XIncludes are transcluded in the

temporary preview file.
• Save option favorInteroperability in XMLmind XML Editor - Configuration and Deployment

is turned on, which is the case by default, and the XHTML document to be previewed contains
processing instructions. Processing instructions are removed from temporary preview file.

If you want to preview the document being edited as is, do not use XHTML → Preview.
Instead please use Tools → Helper Application → Open Document in Helper Ap-
plication.

Check External References

Checks all the links to external resources found in the document being edited. All kinds of external
resources are checked for existence: images, audio, video, PDF documents, HTML pages, etc. When
the resource is an HTML page and the link ends with a fragment (e.g. "#bar" in
"../doc/foo.html#bar") then this fragment is also checked for existence.

4.1. Convert Document sub-menu

Convert to RTF (Word 2000+)

Converts the document being edited to RTF (Rich Text Format) using XMLmind XSL-FO Converter
(see http://www.xmlmind.com/foconverter/). The document generated by this command can be edited
and printed using Microsoft® Word 2000 and above.

Convert to WordprocessingML (Word 2003+)

Converts the document being edited to WordprocessingML using XMLmind XSL-FO Converter.
The document generated by this command can be edited and printed using Microsoft® Word 2003
and above.

6A <link rel="stylesheet" href="file:/C:/src/9xxe/doc/resources/xmlmind.css"> element will be added in the head
element just after the title element.
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Convert to Office Open XML (Word 2007+)

Converts the document being edited to Office Open XML (.docx file) using XMLmind XSL-FO
Converter. The document generated by this command can be edited and printed using Microsoft®
Word 2007 and above.

Convert to OpenDocument (OpenOffice.org 2+)

Converts the document being edited to OpenDocument (.odt file) using XMLmind XSL-FO Con-
verter. The document generated by this command can be edited and printed using OpenOffice.org
2 and above.

Convert to PDF

Converts the document being edited to PDF (Adobe® Portable Document Format, also known as
Acrobat®) using RenderX XEP (see http://www.renderx.com/), if its plug-in has been installed, and
Apache FOP otherwise (see http://xmgraphicsl.apache.org/fop/).

All the above Convert commands display the URL chooser dialog box rather than the standard file
chooser dialog box. That is, you must specify the URL (Uniform Resource Locator) of a save file.

Note that these commands can create directories on the fly, if needed to. For example, if you specify
http://www.acme.com/docs/report43/mydoc.pdf as the URL of the save file and if directory re-
port43/ does not exist, this directory will be created during command execution.

5.The XHTML toolbar

The XHTML tool bar starts with a number of “text style” toggles. These toggles emulate the behavior
of the Bold, Italic, Underline, etc, toggles found in the tool bars of almost all word-processors. More
information about text style toggles in About “text style” toggles in XMLmind XML Editor - Online
Help.

Figure 1. Toggles found at the beginning of the XHTML tool bar

In the above screenshot, the caret is inside an i element and the user clicked the arrow button next to a
“italic text style” toggle.

Toggle i

“Toggle” element i. Next to this toggle is found an arrow button displaying a menu containing ad-
ditional checkboxes for the following elements: em, dfn, cite.

Toggle b

“Toggle” element b. Next to this toggle is found an arrow button displaying a menu containing ad-
ditional checkboxes for the following elements: strong, abbr.
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Toggle tt

“Toggle” element tt. Next to this toggle is found an arrow button displaying a menu containing
additional checkboxes for the following elements: code, var, kdb, samp.

Change case

Displays a menu letting the user change the character case of selected text. If a single node is selected,
this converts the character case of all the text contained in this node. If there is no selection of any
kind, this converts the character case from caret position to end of word, then it moves the caret to
the next word.
lowercase

All characters are converted to lowercase characters. Keyboard shortcut: Esc+l.
UPPERCASE

All characters are converted to uppercase characters. Keyboard shortcut: Esc+u.
Capitalize Each Word

First character of a word is converted to an uppercase character. The other characters are con-
verted to lowercase characters.Keyboard shortcut: Esc+c.

Convert to plain text

Convert implicit or explicit selection to plain text.

Add link

Converts the selection, if any, to a link; simply inserts an empty link at caret position otherwise. A
link is an a element having an href attribute.

Set ID

This button displays a menu having 2 entries: Set ID and List Anchors and Links.

The List Anchors and Links menu entry displays a dialog box letting the user search and select
anchors (that is, any element having an ID) and links. Its Copy button copies selected ID or link
target to the clipboard.

Decrease nesting level

Convert a paragraph to a list item and a list item to a paragraph, the new element having a lesser
nesting level than the original one. This button automatically splits lists when needed to.

This is the inverse command of "Increase nesting level". More Information below [9].

Increase nesting level

Convert a paragraph to a list item and a list item to a paragraph, the new element having a greater
nesting level than the original one. This button automatically creates lists or merges adjacent lists
when needed to.

Note that the two above buttons strictly alternate between paragraphs and list items. This means that
you'll often have to click a button twice in a row. For example, in order to create a nested list, first
click anywhere inside a list item and then click "Increase nesting level" twice. First click converts
the list item to a plain paragraph contained in the preceding list item. Second click converts this
paragraph to the first item of a new nested list.

For the two above buttons to function, any of the following conditions should be met:
• A sequence of list items must be explicitly selected.
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• A list must be explicitly selected. This is equivalent to selecting all its items.
• A sequence of blocks starting with a paragraph must be explicitly selected.
• A paragraph must be implicitly selected. In order to implicitly select a paragraph, suffice to click

anywhere inside it. However if this paragraph is the first child of a list item, then it's the list item
which is implicitly selected.

• A list item to be implicitly selected. In order to implicitly select a list item, suffice to click anywhere
inside it.

When a paragraph is to be converted to a new list using this "Increase nesting level"
button, there is a quick and simple way to specify the kind of list to be created:

If the paragraph is empty, simply type "*", "-", "1.", "a.", "A.", "i.", "I.", optionally
followed by space characters, in it.

•

• If the paragraph is not empty, type "*", "-", "1.", "a.", "A.", "i.", "I.", followed
by at least one space character, at the very beginning of it.

These “prefixes” are used to create respectively: ul, ul, ol, ol[lower-alpha], ol[upper-
alpha], ol[lower-roman], ol[upper-roman], as if the "Change list type" button below
was automatically used.

Change list type

Displays a popup menu allowing to change the type of the current list.

The list must be explicitly or implicitly selected. In order to implicitly select a list, suffice to click
anywhere inside it.

Add list

Displays a menu allowing to select a type of list (ul, ol, dl). The chosen list is added after node
selection or after caret at a location where it is valid to do so.

Add p

Add a p element after node selection or after caret at a location where it is valid to do so.

Add li or dt+dd

Add a li element or a dt/dd pair after current list item. For this command to work, suffice to click
anywhere inside an ul, ol or dl element.

Add pre

Add an pre element after node selection or after caret at a location where it is valid to do so.

Menu entry "Normalize Whitespace" normalizes whitespace in implicitly or explicitly selected
pre element. Normalizing whitespace means: expanding tab characters to a number of space char-
acters and removing the space characters which are common to the beginning of all text lines (that
is, removing the superfluous “indentation” in the pre element, if any).

Add img

Displays a menu letting the user:
• insert an img element at caret position;
• OR add a div element containing an img or a figure element containing an img (XHTML 5 only)

after node selection or after caret at a location where it is valid to do so;
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• OR add a div element containing an img and a map after node selection or after caret at a location
where it is valid to do so.

After using this "img+map" menu item, right-click anywhere inside the newly inserted map element
and select "Edit Image Map" from the contextual popup menu to display an image map editor.
This image map editor allows to add “hot areas” to your image. More information in Section 17,
“The "Edit Image Map" dialog box” in XMLmind XML Editor - Online Help.

Add MathML equation

(XHTML 5 only.) Displays a menu letting the user add various kinds of MathML equations after
node selection or after caret at a location where it is valid to do so.

Insert media object

(XHTML 5 only.) This toolbar button is present only when an XHTML 5 document is opened.
Displays a menu letting the user insert a media element at caret position.
audio

XHTML 5 audio element allowing to add audio to your document. More information in Sec-
tion 16, “The media player dialog box” in XMLmind XML Editor - Online Help.

video

XHTML 5 video element allowing to add video to your document. More information in Sec-
tion 16, “The media player dialog box” in XMLmind XML Editor - Online Help.

iframe(youtube)

An iframe element showing a sample YouTube™ video. More information in Section 5.2, “The
iframe editor dialog box” [14].

Add heading

Displays a menu which allows to add an h1, h2, h3, etc, element after node selection or after caret
at a location where it is valid to do so.

Add section

(XHTML 5 only.) Displays a menu which allows to add a section, aside, article, header or
footer element after node selection or after caret at a location where it is valid to do so.

Add table

Displays a menu which allows to add several styles of tables after node selection or after caret at a
location where it is valid to do so.

Table editor

See Section 5.1, “Table editor” [11].

5.1.Table editor

The following table editing commands fully support HTML tables. Most table editing commands can
be repeated by using Edit → Repeat (Ctrl+A).

DescriptionMenu itemButton

Insert a column before column containing specified cell.Insert Be-
fore

Table
column
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DescriptionMenu itemButton

For a com-
mand in this

Insert a column after column containing specified cell.Insert
After

menu to work,
Cut to the clipboard the column containing specified cell.Cutclick any-

where inside
Copy to the clipboard the column containing specified cell.Copya cell (or expli-

citly select a Paste copied or cut column before column containing specified cell.Paste Be-
fore

cell or an ele-
ment having a
cell ancestor). Paste copied or cut column after column containing specified cell.Paste After

Delete the column containing specified cell.Delete

Sort all the rows of the table according to the string values of the
cells of the “selected column”. (The “selected column” is the column
containing specified cell.)

Sort Rows

A dialog box is displayed allowing to specify the following sort
options:

Order

Dictionary is the language-specific alphabetical order. Example:
(Charles, best, Albert) is sorted as (Albert, best, Charles).

Numeric. The string value of a cell is expected to start with a
number. Example: (+15.0%, 1.50%, -20%) is sorted as (-20%,
1.50%, +15.0%).

Lexicographic is the order of Unicode characters. Example:
(Charles, best, Albert) is sorted as (Albert, Charles, best).

Dictionary and Numeric orders will cause this menu item to
fail, unless the language of the table can be determined (i.e.
lookup for the lang or xml:lang attribute).

Direction

Ascending means: A to Z, low to high. Descending means: Z
to A, high to low.

Note that:

• Header/footer rows (i.e. thead) are never sorted.
• The contents of row groups (i.e. tbody) are sorted separately.

Insert a row before row containing specified cell.Insert Be-
fore

Table
row

For a com-
mand in this

Note that row editing commands are enabled, not
only by implicitly or explicitly selecting a table cell
or any of its descendants, but also by explicitly se-
lecting a table row.

menu to work,
click any-
where inside
a cell (or expli-
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DescriptionMenu itemButton

Insert a row before row containing specified cell.Insert
After

citly select a
cell or an ele-
ment having a

Cut to the clipboard the row containing specified cell.Cutcell ancestor)
or explicitly
select a row.

Copy to the clipboard the row containing specified cell.Copy

Paste copied or cut row before row containing specified cell.Paste Be-
fore

Paste copied or cut row after row containing specified cell.Paste After

Delete the row containing specified cell.Delete

Increment the number of columns spanned by specified cell.Increment
Column Span

Table
cell

For a com-
mand in this

Decrement the number of columns spanned by specified cell.Decrement
Column Span

menu to work, Increment the number of rows spanned by specified cell.Increment
Row Span

click any-
where inside

Decrement the number of rows spanned by specified cell.Decrement
Row Span

a cell (or expli-
citly select a
cell or an ele-

Displays a dialog box allowing to give a background color to spe-
cified cell.

Set Color
(XHTML 1.0

ment having a
cell ancestor).

and 1.1 config-
urations)

Unlike the other entries of this menu, this entry al-
lows to give a background color, not only to spe-
cified cell, but also to one or more of any of the
following explicitly selected elements: table, col-
group, col, thead, tfoot, tbody, tr, td, th.

Displays a dialog box allowing to format specified cell. This dialog
box makes it easy and safe setting the style attribute of specified

Format
(XHTML 5
configuration) cell to one or more of the following CSS properties: text-align,

vertical-align, background-color, border-style, border-width, border-
color.

Unlike the other entries of this menu, this entry al-
lows to format, not only to specified cell, but also
one or more of any of the following explicitly selec-
ted elements: table, colgroup, col, thead, tfoot,
tbody, tr, td, th.
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5.2.The iframe editor dialog box

By default, an iframe element is rendered by embedding a Web browser in the styled view.

Figure 2. An embedded web browser displaying a sample YouTube™ video

This feature, which is based on JavaFX®, will not work if the Java™ runtime used to run
XXE is older than version 1.8.0_40. Moreover, this feature may be explicitly disabled by
unchecking Options → Preferences, General|Feature, "In the styled view, render audio
and video elements by embedding a media player" in XMLmind XML Editor - Online
Help.

A newly embedded Web browser is not configured yet (e.g. does not point to any HTML content) and
just looks like an empty gray rectangle.

Figure 3. The right-click popup menu of the embedded Web browser

In order to configure a media player, you may either:
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• double-click inside it;
• OR right-click in it and select the Edit menu item;
• OR drag and drop an HTML file onto it.

The three above actions all display the iframe editor dialog box.

Figure 4. the iframe editor dialog box

An iframe element is configured as follows:

1. Specify the location of the HTML page to be displayed by the embedded Web browser. This location
may be an absolute or relative URL. A relative URL is relative to the URL of the document being
edited.

This field corresponds to the src attribute of the iframe element.

2. Optionally, give a width and/or a height to the iframe. These dimensions are specified in pixels.
The default size is 300x200. When a single dimension is specified, the other dimension is automat-
ically computed using a 2:1 width/height ratio.

These fields corresponds to the width and height attributes of the iframe element.

3. Optionally, specify security options for the HTML content of the iframe element by checking one
or more security option checkboxes.
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Note that settings such security options have no effect on the Web browser embedded in the styled
view of XXE. These checkboxes correspond to values of the sandbox attribute of the iframe ele-
ment. For example, checking "Apply all security rules" alone adds attribute sandbox="" to the
iframe element. Other example, checking "Apply all security rules" then "Allow popups" and
"Allow scripts" adds attribute sandbox="allow-popups allow-scripts" to the iframe element.

The simplest and quickest way to fill the fields of the above dialog box is:

Using your Web browser, visit the YouTube page containing your video.a.
b. Right-click the video and select entry "Copy embed code" from the contextual menu.
c. Click the  button.

This button parses the content of the clipboard (which expected to contain something
like <iframe...src="...) and then uses the results to initialize some of the fields of
the above dialog box.

6. Custom bindings

ActionKeystroke

Same as menu item Move Up [6].Alt+Shift+Up

Same as menu item Move Down [6].Alt+Shift+Down

Same as toolbar button Decrease nesting
level [9].

Alt+Shift+Left

Same as toolbar button Increase nesting level [9].Alt+Shift+Right

Insert a newline character if possible. Otherwise,
if caret is at the beginning of a paragraph, list item

Enter

or a few other kinds of block, insert same block
before. Otherwise, if caret is at the end of a block,
insert same block after. Otherwise, split block.

Delete selection if any. Otherwise, if caret is at
the end of a paragraph, list item or a few other

Del

kinds of block, join with following block. Other-
wise, delete character following caret.

Delete selection if any. Otherwise, if caret is at
the beginning of a paragraph, list item or a few

BackSpace

other kinds of block, join with preceding block.
Otherwise, delete character preceding caret.

Add same block after the paragraph, list item or
a few other kinds of block which is the ancestor
of selected node.

Ctrl+Enter

Add same block before the paragraph, list item or
a few other kinds of block which is the ancestor
of selected node.

Ctrl+Shift+Enter

Inserts a br at caret and moves caret after inserted
br.

Shift+Enter
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ActionApplication Event

Drop an object. • On a a element having an href attribute,
change the value of this attribute to the dropped
string.

• On an img element, change the value of the src
attribute to the dropped string.

• Elsewhere
• If the object being dropped represents an

URL or an absolute filename, open the cor-
responding document in XMLmind XML
Editor.

• Otherwise, displays a popup menu allowing
to paste the dropped text or XML before, into
or after the drop location.

Resize the image, but always preserve its aspect
ratio.

Drag one of the “handles” displayed around an
image. (The “handles” are displayed after clicking
on the image.)

Pressing Ctrl (Cmd on the Mac) while dragging
the handle allows to distort the image.

Resize the table column. More precisely, this gives
an appropriate percent width (e.g. <col-

group width="35%">) to all table columns.

Drag a separator found between two table
columns.

If the document containing the
table is an XHTML 5 document,
then the colgroup element has
no width attribute. In such case,
the resize table column action
has to use the style attribute
( e . g .  < c o l -

group style="width: 35%">).
In practice, this means that un-
less you select the "Emulate
Web Browser" CSS
stylesheet [4], you'll not see
the table columns correctly res-
ized.

A.Table rendering

Deprecated attributes (that is, those specified in the transitional DTD 1.0) are not supported. The following
attributes are either completely ignored or partially supported. All the other attributes are supported.

SupportAttribute

Ignored.table width

Value larger than 1 treated like 1.table border
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SupportAttribute

Ignored.table cellspacing

Ignored.table cellpadding

All forms including "20%", "3*" or "0*" are sup-
ported.

col (or colgroup) width

A column must contain at least one cell with a
column span equal to 1 for the width attribute to
have an effect.

Values justify and char are rendered like left.align

Ignored. See align.char

Ignored. See align.charoff

B. Parameters of the XSLT stylesheets used to convert XHTML to
XSL-FO

DescriptionDefault
Value

ValueParameter

Specifies whether CSS styles specified in XHTML
style attributes, style and link elements also
apply to the XSL-FO file.

'yes''no' | 'yes'apply-css-

styles

Depending on the context, the following CSS
properties are converted to their equivalent XSL-
FO attributes. The corresponding shorthand CSS
properties are supported too. Any other CSS prop-
erty is ignored. Generated content (:before,
:after) is ignored too.

• margin-top, margin-right, margin-bottom, mar-
gin-left.

• padding-top, padding-right, padding-bottom,
padding-left.

• border-top-style, border-right-style, border-bot-
tom-style, border-left-style.

• border-top-width, border-right-width, border-
bottom-width, border-left-width.

• border-top-color, border-right-color, border-
bottom-color, border-left-color.

• background-color, background-image, back-
ground-repeat, background-position.

• color.
• font-family, font-style, font-weight, font-size.
• text-decoration.
• text-align.
• text-indent.
• vertical-align.
• line-height.
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DescriptionDefault
Value

ValueParameter

• list-style-type, list-style-position, list-style-im-
age.

• width, height.
• caption-side.
• border-spacing.

Note that styles specified this way supersede all
the other ways to specify the presentation in the
output file, that is, parameters like base-font-
size [19] or the presentation attributes (xsl:at-
tribute-set) specified in the XSLT stylesheets
that generate the XSL-FO file.

This feature, which leverages
XMLmind XML Editor CSS en-
gine, will not work unless the
XSLT stylesheets are being in-
voked by an XMLmind applica-
tion such as XMLmind XML Ed-
itor or XMLmind XSL Utility.

The size of the font used for most body elements
(paragraphs, tables, lists, etc). All the other font
sizes are computed relatively to this font size.

'10pt'Length in ptbase-font-

size

Appended after the external URL referenced by an
a element. Ignored unless show-external-

links='yes' [22].

']'Stringexternal-

href-after

Separates the text of an a element from its refer-
enced external URL. Ignored unless show-extern-
al-links='yes' [22].

' ['Stringexternal-

href-before

The font family used by default for all elements.'serif'One or more
font families

font-family

separated by
commas

Specifies the contents of the central part of a page
footer. See the section called “Specifying a header
or a footer” [23].

''A mix of text
and variables.

footer-cen-

ter

Specifies the proportional width of the central part
of a page footer. See the section called “Specifying
a header or a footer” [23].

'6'String repres-
enting an in-
teger larger

footer-cen-

ter-width

than or equal to
1.

Specifies the contents of the left part of a page
footer. See the section called “Specifying a header
or a footer” [23].

' { { e v e n -

page-num-

ber}}'

A mix of text
and variables.

footer-left
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DescriptionDefault
Value

ValueParameter

Specifies the proportional width of the left part of
a page footer. See the section called “Specifying a
header or a footer” [23].

'2'String repres-
enting an in-
teger larger

f o o t e r -

left-width

than or equal to
1.

Specifies the contents of the right part of a page
footer. See the section called “Specifying a header
or a footer” [23].

' { { o d d -

page-num-

ber}}'

A mix of text
and variables.

f o o t e r -

right

Specifies the proportional width of the right part
of a page footer. See the section called “Specifying
a header or a footer” [23].

'2'String repres-
enting an in-
teger larger

f o o t e r -

right-width

than or equal to
1.

Specifies whether an horizontal rule should be
drawn above the page footer. See the section called
“Specifying a header or a footer” [23].

'yes''no' | 'yes'footer-sep-

arator

Specifies the contents of the central part of a page
header. See the section called “Specifying a header
or a footer” [23].

' { { d o c u -

m e n t -

title}}'

A mix of text
and variables.

header-cen-

ter

Specifies the proportional width of the central part
of a page header. See the section called “Specifying
a header or a footer” [23].

'6'String repres-
enting an in-
teger larger

header-cen-

ter-width

than or equal to
1.

Specifies the contents of the left part of a page
header. See the section called “Specifying a header
or a footer” [23].

''A mix of text
and variables.

header-left

Specifies the proportional width of the left part of
a page header. See the section called “Specifying
a header or a footer” [23].

'2'String repres-
enting an in-
teger larger

h e a d e r -

left-width

than or equal to
1.

Specifies the contents of the right part of a page
header. See the section called “Specifying a header
or a footer” [23].

''A mix of text
and variables.

h e a d e r -

right

Specifies the proportional width of the right part
of a page header. See the section called “Specifying
a header or a footer” [23].

'2'String repres-
enting an in-
teger larger

h e a d e r -

right-width

than or equal to
1.

Specifies whether an horizontal rule should be
drawn below the page header. See the section called
“Specifying a header or a footer” [23].

'yes''no' | 'yes'header-sep-

arator

Specifies whether words may be hyphenated.'no''no' | 'yes'hyphenate
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DescriptionDefault
Value

ValueParameter

Specifies whether text (e.g. in paragraphs) should
be justified (that is, flush left and right) or just left
aligned (that is, flush left and ragged right).

'no''no' | 'yes'justified

The orientation of the printed page.'portrait''portrait' |
'landscape'

page-orient-

ation

Appended after the page number pointed to by an
a element. Ignored unless show-xref-

page='yes' [22].

']'Stringpage-ref-

after

Separates the text of an a element from the page
number it points to. Ignored unless show-xref-
page='yes' [22].

' ['Stringpage-ref-be-

fore

A convenient way to specify the size of the printed
page.

'A4'Allowed values
are: 'Letter',

paper-type

It is also possible to specify a custom paper type
by ignoring the paper-type parameter and directly

' L e g a l ' ,
' L e d g e r ' ,
'Tabloid' ,

specifying the page-width [25] and page-

height [24] parameters.
'A0', 'A1',
'A2', 'A3',
'A4', 'A5',
'A6', 'A7',
'A8', 'A9',
'A10', 'B0',
'B1', 'B2',
'B3', 'B4',
'B5', 'B6',
'B7', 'B8',
'B9', 'B10',
'C0', 'C1',
'C2', 'C3',
'C4', 'C5',
'C6', 'C7',
'C8', 'C9',
'C10' (case-
insensitive).

When XMLmind XSL-FO converter is used to
convert the intermediate XSL-FO file to RTF,

'yes''no' | 'yes's e t - o u t -

line-level

.odt, .docx, etc, and the value of this parameter
is 'yes', consider the h1, h2, ... h6 elements as
being headings participating in the outline of the
MS-Word or OpenOffice/LibreOffice document.

The outline level is directly taken from the name
of the heading element: level=1 for h1, level=2 for
h2, etc.

Note that h1, h2, ... h6 elements contained inside
a blockquote, details, dialog, fieldset, fig-
ure or td element (that is, a secondary “sectioning
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DescriptionDefault
Value

ValueParameter

root”) never participate in the outline of the MS-
Word or OpenOffice/LibreOffice document.

Specifies whether the external URL referenced by
an a element should be displayed right after the
text contained by this element.

'no''no' | 'yes'show-extern-

al-links

Example: show-external-links='yes' causes
<a href="http://www.oasis-open.org/">Oas-

is</a> to be rendered as follows: Oasis [ht-
tp://www.oasis-open.org/].

Specifies whether a numbered list should be gener-
ated for a XHTML map element, with one list item
per area element.

'yes''no' | 'yes'show-map-

links

A list item contains the link specified by the area
element. No list items are generated for “dead
areas” (area elements specifying no link at all).

Specifies whether the page number corresponding
to the internal link target referenced by an a ele-

'no''no' | 'yes'show-xref-

page

ment should be displayed right after the text con-
tained by this element.

Example: show-xref-page='yes' causes <a

href="#introduction">Introduction</a> to
be rendered as follows: Introduction [3].

Specifies whether the document should be printed
double sided.

'no''no' | 'yes'two-sided

Specify which bullet character to use for an ul/li
element. Additional characters are used for nested
li elements.

'&#x2022;

&#x2013;'

One or more
bullet charac-
ters separated
by spaces

ul-li-bul-

lets

For example, if ul-li-bullets="* - +", "*" will
be used for ul/li elements, "-" will be used for
ul/li elements contained in a ul/li element and
"+" will be used for ul/li elements nested in two
ul/li elements.

Specifies whether XMLmind XSL-FO Converter
should render the fo:blocks representing specified
elements as fo:tables.

' a s i d e

blockquote'

A string con-
taining zero or
more element

xfc-render-

as-table

This parameter enables a workaround for a limita-
tion of XMLmind XSL-FO Converter: a fo:block

names separ-
a t e d  b y
whitespace.

having a border and/or background color and con-
Supported ele-
ment names

taining several other blocks, lists or tables is very
poorly rendered in RTF, WML, DOCX and ODT.

are: aside,
blockquote,
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DescriptionDefault
Value

ValueParameter

footer, head-
er, nav.

Specifying a header or a footer

The header or the footer of a generated PDF, RTF, etc, page has 3 columns.

Figure B.1. Layout of a header

header-centerheader-left header-right

header-center-widthheader-left-width header-right-width

header-separator

The width of these columns may be specified using the header-left-width [20], header-center-
width [20], header-right-width [20] parameters for the header and the footer-left-width [20],
footer-center-width [19], footer-right-width [20] parameters for the footer.

The width of a column is specified as an integer which is larger than or equal to 1. This value is the
proportional width of the column. For example, if the left column has a width equal to 2 and the right
column has a width equal to 4, this simply means that the right column is twice (4/2 = 2) as wide as the
left column.

The contents of these columns may be specified using the header-left [20], header-center [20],
header-right [20] parameters for the header and the footer-left [19], footer-center [19],
footer-right [20] parameters for the footer.

When header-left, header-center, header-right are all specified as the empty string, no header is
generated. When footer-left, footer-center, footer-right are all specified as the empty string,
no footer is generated.

The content of a column is a mix of text and variables. Example: "Page {{page-number}} of {{page-
count}}".

Supported variables are:

{{document-title}}

The title of the document.

{{current-heading}}

In principle, the title of the last h1, h2, h3, etc, element being rendered.

No effect unless the XSLT stylesheets are customized in order to give a value to this variable.

<fo:marker

  marker-class-name="current-heading">

  ...

</fo:marker>
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{{page-number}}

Current page number.

{{odd-page-number}}

Current page number; empty when a double-sided output is being generated and the current page
number is even.

{{even-page-number}}

Current page number when a double-sided output is being generated and the current page number
is even; empty otherwise.

{{page-count}}

Total number of pages of the document.

{{break}}

A line break.

{{image(URI)}}

An image having specified URI. A relative URI is resolved against the current working directory.
Example: "{{image(artwork/logo.svg)}}".

The image is displayed at its intrinsic size. If it is too tall to fit in a page header or footer, you may
need to increase the height of the header or footer by using the following parameters: header-
height [24], body-top-margin [24], footer-height [24], body-bottom-margin [24].

{{url(URI)}}

A styled hyperlink to specified URI. No attempt is made to resolve a relative URI. The specified
URI may be optionally followed by a space character and then, the text of the link. Examples:
"{{url(http://www.xmlmind.com/xmleditor/)}}", "{{url(http://www.xmlmind.com/xmled-
itor/ XMLmind XML Editor)}}"

Page layout parameters

DescriptionDefault
Value

ValueParameter

See figure [25] below.'0.5in'Lengthbody-bot-

tom-margin

See figure [25] below.'0.5in'Lengthbody-top-

margin

See figure [25] below.'0.4in'Lengthf o o t e r -

height

See figure [25] below.'0.4in'Lengthh e a d e r -

height

See figure [25] below.'0.5in'Lengthpage-bot-

tom-margin

The height of the printed page.Depends on
parameter pa-
per-type.

Length. Ex-
a m p l e :
'297mm'.

page-height
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DescriptionDefault
Value

ValueParameter

See figure [25] below.If parameter
two-sided is

Lengthpage-inner-

margin

specified as
'yes' then
'1.25in' oth-
erwise '1in'.

See figure [25] below.If parameter
two-sided is

Lengthpage-outer-

margin

specified as
'yes' then
'0.75in' oth-
erwise '1in'.

See figure [25] below.'0.5in'Lengthpage-top-

margin

The width of the printed page.Depends on
parameter pa-
per-type.

Length. Ex-
a m p l e :
'8.5in'.

page-width

Figure B.2. Page areas

HEADER

FOOTER

PAGE

BODY

page-top-margin

page-bottom-margin

page-inner-margin page-outer-margin

body-top-margin

body-bottom-margin

header-height

footer-height
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Advanced parameters

DescriptionDefault
Value

ValueParameter

If this parameter is not empty and if the value of
the src attribute is a relative URI, then this para-
meter is prepended to the value of the src attribute.

''URI ending
with '/'

i m g - s r c -

path

This low-level alternative to resolve-img-

src='yes' [26] also allows to generate an XSL-
FO file where all the references to graphic files are
absolute URIs.

In the XSL-FO file, convert relative URIs contained
in the href attribute of a elements to absolute

'no''no' | 'yes'resolve-a-

href

URIs. This is done by resolving the relative URI
against the base of the a element.

In the XSL-FO file, convert relative URIs contained
in the src attribute of img elements to absolute

'yes''no' | 'yes'r e s o l v e -

img-src

URIs. This is done by resolving the relative URI
against the base of the img element.

If this parameter is not empty, it must be the value
of an id attribute that occurs in the document being

''ID found in the
s o u r c e

root-id

formatted. The entire document will be loaded, butXHTML docu-
ment formatting will begin at the element identified,

rather than at the root element.

For example, this allows to convert a specific div
element rather than the whole XHTML document.

Screen resolution in DPI. Used to convert px to pt.96.0Numberscreen-res-

olution

System parameters

Such system parameters are not intended to be specified by the end-user. Such system
parameters are documented here only because the end-user may see them referenced in
some dialog boxes, in some configuration files or in the source code of the XSLT stylesheets.

DescriptionDefault
Value

ValueParameter

The name of the XSL-FO processor used to convert
the XSL-FO file generated by the XSLT stylesheets
to the target output format.

If output-

Format [27]
has been spe-

String. Ex-
amples: 'FOP',
'XEP', 'XFC',
'AHF'.

foProcessor

cified and if
system prop-
e r t y
XSL_FO_PRO-
C E S S O R S
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DescriptionDefault
Value

ValueParameter

contains the
list of all
a v a i l a b l e
XSL-FO pro-
cessors, the
default value
is computed,
otherwise the
default value
is ''.

The file extension of the target output file.''String. Ex-
amples: 'ps',

o u t p u t -

Format

'pdf', 'rtf',
'wml', 'docx',
'odt'.
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