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Abstract
This document explains how the XMLmind XML Editor add-on called "Google® virtual drive plug-in" can be
used to turn Google Drive™ into a zero-install, inexpensive, yet capable XML document repository. (Google and
Google Drive are trademarks of Google Inc.)
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1. Why use this add-on?
This add-on allows you to work directly on Google Drive as if it were your local hard drive. It's not a file synchronization tool. It makes accesses to Google Drive in real time. Of course, it does not not require you to install the
Google Drive desktop application on your computer.
This add-on aims to turn Google Drive into a a zero-install, inexpensive, yet capable1 XML document repository.
Such XML document repository is typically used by a group of technical writers working on the same set of files.
That's why this add-on will automatically write-lock XML documents opened in XMLmind XML Editor. Moreover,
saving repeatedly to Google Drive a write-locked document will create only a single revision of this document.
On the downside, Google Drive is very slow2, even compared to other remote storage facilities such as FTP and
WebDAV servers. In rare occasions, Google Drive may become slow to the point of being unusable. It may also
report hard to understand errors. However these errors are always harmless for your files and for XMLmind XML
Editor.
This being said, lots of development efforts have been made to ensure that the combination of XMLmind XML
Editor and the Google virtual drive plug-in always works acceptably.

2. Getting started
You may also want to watch a

screencast showing the following steps.

1

Google Drive automatically keeps old versions of a file (called revisions). Google Drive automatically indexes files in order to implement
full-text search.
2
Not a throughput problem; a very high response time: 0.2 to 20 seconds per request, no matter how simple is this request.
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1.

Download and install the add-on called "Google® virtual drive plug-in" using menu item Options → InstallAddons. Then restart XMLmind XML Editor (XXE for short) as instructed by the application.

2.

Check File → Use the URL Chooser.
This is needed because you cannot use the standard file chooser dialog box to open files and folders found
on a remote storage facility such as Google Drive.

3.

Select File → Folder → Open Folder3. This displays the URL chooser dialog box in XMLmind XML Editor
- Online Help.

4.

Click "New URL" , select "google:/" from the popup menu, then click OK.

5.

The first time you'll do this, you'll be prompted to authorize XXE to access your Google Drive.

After you sign in to your Google account, click Accept and you are done4.

You may need to enable this submenu by checking "Enable the 'File|Folder' Submenu" in Options → Preferences, General|Features section.
This step is slightly more involved if you are using a Java™ 1.6 runtime (like on the Mac, with the .dmg distribution). More information in
Alternate method for authorizing XXE to access your Google Drive [6].
3
4
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A "Browse Files" tool in XMLmind XML Editor - Online Help is now opened on your Google Drive.

6.

Select File → Folder → Open Home Folder.

3

Using Google Drive™ as an XML
Document Repository

7.

Click the dashed line of the folder tab to split the tab area in two parts.

8.

Navigate to a local folder containing all the files comprising an XML document, select it, then drag and drop
it onto your Google Drive.

9.

Close the local folder tab as it is no longer needed.

10. In the Google Drive tab, navigate to the XML document you have just uploaded then double-click its name
to open it in XXE.
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Notice that this document is now write-locked by you in order to prevent your coworkers from overwriting
your changes.
11. Modify your document and press Ctrl+S (Cmd+S on the Mac) to save your changes directly to Google Drive.
Because the document is write-locked by you, saving repeatedly your changes will create only one revision
of the XML file per editing session.
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Alternate method for authorizing XXE to access your Google Drive
This method is automatically selected when a Java™ 1.6 runtime is used to run XXE (like on the Mac, with
the .dmg distribution) or when XXE fails to determine where JavaFX has been installed on your computer
(like when you start XXE using xxe-c.bat).
1.

This prompt is displayed:

At the same time, your Web browser is started and shows this page:

2.

Click Accept. The page displayed by the Web browser changes to:
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3.

Select the authorization code by clicking in the text field and pressing Ctrl+A (Cmd+A on the Mac).
Then press Ctrl+C (Cmd+C on the Mac) to copy the authorization code to the clipboard.

4.

Switch to XXE. Click in the text field of the prompt. Press Ctrl+V (Cmd+V on the Mac) to paste the
authorization key.

5.

Click OK to close the prompt and authorize XXE to access your Google Drive.

3. Teamwork on the Google Drive
Let's suppose Jane Doe (see above example) wants to collaborate with John on writing the document uploaded to
the docs folder.
Jane must proceed as follows:
1.

Start her Web browser and visit her Google Drive.

2.
Select folder docs and click

3.

Share.

Send by email an invitation to John using the dialog box displayed after clicking Share.
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Once John receives Jane's invitation to work on the document found in folder docs, he must proceed as follows:
1.

Start his Web browser and visit his Google Drive. He'll find folder docs in the "Shared with Me" section.

2.

Select folder docs and click "Add to My Drive".

From now, any change (creations, deletions, modifications) made by Jane to the files and sub-folders found
in folder docs will be seen by John. The opposite way around is also true: any change made by John will be
seen by Jane.
3.

John can open, for example, google:/docs/Book.xml5 in XXE by proceeding as explained in steps 1 and 2
of Section 2, “Getting started” [1] and then selecting menu item File → Open. Note that the first time John
will open google:/docs/Book.xml, he too will be asked to authorize XXE to access his Google Drive.
Best pratices
• Identify yourself as a lock owner.
This is done by specifying the email address associated to your Google account in the "Identifier as a
lock owner" field found in the Options → Preferences, Open section in XMLmind XML Editor - Online
Help.
This is really needed because while XXE knows the full name (e.g. "Jane Doe") of the person owning a
Google Drive, it has no access to her/his email address (e.g. "jane.xmlmind.doe@gmail.com").
• In order to be able to compare two revisions of a file (see below [8]), you'll have to enable the comparison of revisions in all the documents you are modifying or creating on Google Drive.
The easiest way to do so automatically is to turn on option "Automatically enable the comparison of revisions" (Options → Preferences, Tools|Revisions section in XMLmind XML Editor - Online Help).
Using this option is almost completely transparent:
• This option just adds a <?xxe-sn unique_serial_number?> processing-instruction to all the elements of
the document. However such processing-instructions just exist at document load time and at document
save time. In other words, unless you use View → XML Source, you'll never see such processing-instructions.
• Having this option always turned on will not slowdown XXE when opening, editing or saving documents.

4.Working with revisions (or “who did what and when?”)
Important
Make sure to have enabled the comparison of revisions for all your documents, otherwise you'll not be
able to compare two revisions of the same document. See Best pratices [8].
1.

Open the folder containing your document by selecting menu item File → Folder → Open Current Folder
(Ctrl+Shift+O; Cmd+Shift+O on the Mac).

5

For John, google:/ denotes the root of his own Google Drive, and not the root of Jane's Google Drive.
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2.

Right-click on the name of your document to display this popup menu.

3.

Click Revisions. This entry displays the following dialog box:

This dialog box lists all the revisions of the selected document. Revisions are ordered from most recent (top
of the list; bigger revision numbers) to least recent (bottom of the list; smaller revision numbers). An item of
the list contains the following information: the number of the revision, its creation date, the name of the user
who created it, its file size.

Important
The "Open Selected Revisions" and "Compare Two Revisions" buttons will always be disabled
(“grayed”) when selected file cannot be opened in XXE. This happens for example for files having
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a .html extension which are considered to contain plain HTML (text/html) rather than XHTML
(application/xhtml+xml).
When you know that files having a given extension actually contain XML, you may instruct XXE
to open such files by using Options → Preferences, Tools|Helper Applications in XMLmind XML
Editor - Online Help. As expected, the settings will also have an effect on the "Open Selected Revisions" and "Compare Two Revisions" buttons.
4.

Click "Open Selected Revisions" to open in XXE one or more revisions selected from the list. The most recent
revision is opened normally, in read-write mode. Older revisions are opened in read-only mode.

Tip
Using File → Save As on a document opened in read-only mode will cause it to switch to the normal
read-write mode.
This precisely how you can revert to an old revision of a document. Example: saving
"/pages/page1.xhtml 1" (which identifies revision #1 of file "/pages/page1.xhtml") as
"/pages/page1.xhtml" will cause this document to revert to its initial revision.
5.

You may also want to click "Compare Two Revisions" to directly compare using the Compare tool in XMLmind
XML Editor - Online Help two revisions selected from the list.

5. Advanced usage
5.1. Working with several Google Drives
A person may have several Google accounts, hence several Google Drives. XXE allows to work directly on all
these Drives at the same time. For example, copy some files by dragging files found in a first Drive and then
dropping them onto a second Drive.
Example: let's suppose Jane has two Google accounts. First account is associated to email address
<jane.xmlmind.doe@gmail.com>. Second account is associated to (more personal) email address
<jane.k.doe.@gmail.com>.
She'll use "google:/" to refer to the root folder of her default Google Drive, the one associated to email address
<jane.xmlmind.doe@gmail.com>. (Remember how she authorized XXE to access her Google Drive: she first
signed in to her <jane.xmlmind.doe@gmail.com> Google account. See above [2].)
She'll use "google://personal/" to refer to the root folder of her other Google Drive. Here, "personal" is an
arbitrary Drive identifier which is entirely Jane's choice.
Of course, the first time Jane will use "google://personal/", she'll be prompted to authorize XXE to access her
"personal" Drive, just like she was prompted to authorize XXE to access her default Drive. When this will happen,
Jane will take great care to sign in to her <jane.k.doe.@gmail.com> Google account, and not to her
6
<jane.xmlmind.doe@gmail.com> Google account .

About "google:" URLs
Technically speaking, "google:/" is an URL having no authority, while "google://personal/" is an
URL having an authority called "personal". The two slashes ("//") preceding the name of the authority
are absolutely required.

6

Otherwise, "google:/" and "google://personal/" would be two different ways to refer to the same Google Drive.
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5.2. Revoking XXE authorization to access your Google Drive
Note
You may want to revoke XXE authorization to access your Google Drive if you find that the "Google®
virtual drive plug-in" is not useful. But there are also other, more imperative, reasons to do that.
When the "Browse Files" tool (and also the URL chooser dialog box) constantly shows a blank window
(as if your Google Drive were completely empty), when opening a document in XXE constantly fails
after displaying the following "invalid_grant" alert:

then it's time to revoke XXE authorization to access your Google Drive in order to be able to grant this
authorization again, starting from a clean room state.
This is a two-step operation. First step, actually revoke XXE authorization to access your Google Drive:
1.

Start your Web browser and sign in to the Google account associated to the Google Drive accessed by XXE.

2.

Click your photo. This displays a popup window.

3.

Click Account. The Web browser now displays an "Accounts" page having a navigation menu at its left.

4.

Click "Security" and then "Account Permissions".
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5.

Click "XMLmind XML Editor" and then click "Revoke access".

Second step, inform XXE about what you did:
1.

Select menu item Options → Preferences.

2.

After the Preferences dialog box is displayed, select "Add-on|Google Drive" in its left pane.

3.

Select the identifier of the Drive for which you want to revoke XXE authorization. Note that "(My Drive)"
is the identifier automatically given to your default Google Drive (see Section 5.1, “Working with several
Google Drives” [10]).

4.

Click Remove.

5.

Click OK to close the Preferences dialog box.

5.3. Miscellaneous useful information about this add-on
• It's not possible to download (and hence, open in XXE) files created using Google Docs. Moreover listing the
revisions of this kind of files always shows a blank window.
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• Write locks are implemented by the means of the description field of a file7. Therefore, you must not handedit this field in the case of documents edited using XXE.

• XXE authorizations to access one or more Google Drives are stored in file
ences_dir/gdrive/StoredCredentials, where directory XXE_user_preferences_dir/ is:
• $HOME/.xxe8/ on Linux.
• $HOME/Library/Application Support/XMLmind/XMLEditor8/ on the Mac.
• %APPDATA%\XMLmind\XMLEditor8\ on Windows XP, Vista, 7 and 8.

XXE_user_prefer-

Example: C:\Documents and Settings\john\Application Data\XMLmind\XMLEditor8\ on Windows
XP. C:\Users\john\AppData\Roaming\XMLmind\XMLEditor8\ on Windows Vista, 7 and 8.
If you cannot see the "Application Data" directory using Microsoft Windows File Manager, turn on
Tools>Folder Options>View>File and Folders>Show hidden files and folders.
If you use XXE on several computers, after authorizing XXE on one computer, you may safely copy StoredCredentials to the XXE_user_preferences_dir/gdrive/ directory of the other computer. Doing this will avoid
you to also authorize XXE to access Google Drive from the other computer.

7

Google Drive does not natively support file locking. Though there are more elegant ways to implement application-level file locking, we have
chosen to “hijack” the description field for efficiency reasons.
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